All Systems Nominal

Incident #61

Status: Resolved
May 10 2023

Title: Mobile App Unavailable in Google Play

22:44
Identified - Initial status of Identified
22:44
Update - Our app is temporarily not available for download from the Google Play store. We are working with Google to address the issue as quickly. We apologize for the inconvenience
Sep 18 07:57
Resolved - The issue had been resolved.

Service Status

Cloud Console - Nominal

Cloud Workspaces - Nominal

Support Portal - Nominal

Omni Channel - Nominal

Releases - Nominal

Marketplace - Nominal

Push Gateway - Nominal

EU - Cloud Workspaces - Nominal

US - Cloud Workspaces - Nominal

General Alerts - Nominal